Bulk Billing Delays

Incident Report for Smokeball USA

Resolved

Bulk Billing delays have been resolved, and all invoices are now processing as expected. We thank you for your patience.
Posted Jul 01, 2025 - 12:10 CDT

Identified

We have identified the cause of the bulk billing delays and are in the process of resolving this issue. We appreciate your patience and we will provide an update as soon as possible.
Posted Jul 01, 2025 - 11:52 CDT

Investigating

We are currently investigating issues with bulk billing delays.
Posted Jul 01, 2025 - 11:02 CDT
This incident affected: Smokeball Billing.