Delays with invoicing

Incident Report for Smokeball USA

Resolved

Our team has resolved the delays with time entry changes and finalizing PDF invoices.
Posted Apr 01, 2026 - 16:05 CDT

Investigating

We are aware of delays with finalized invoices loading and changes to time entries on the draft invoice screen.
Posted Apr 01, 2026 - 15:29 CDT
This incident affected: Smokeball Billing.