Delays with invoice processing
Incident Report for Smokeball USA
Resolved
Billing actions are now completing as expected. This includes invoice creation/processing, payment processing, emailing, check printing, and time entry creation. Thank you for your patience.
Posted May 01, 2024 - 10:45 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 01, 2024 - 10:38 CDT
Investigating
We are aware of delays with creating invoices, applying payments, finalizing invoices, and sending invoices. Our team is investigating. Thank you for your patience.
Posted May 01, 2024 - 10:06 CDT
This incident affected: Smokeball Billing.