Reports not loading in Smokeball

Incident Report for Smokeball USA

Resolved

Reports are now loading as expected. We appreciate your patience. Thanks!
Posted May 20, 2026 - 16:59 CDT

Update

The issue has been identified and escalated to Amazon Web Services. We are awaiting their response.
Posted May 20, 2026 - 16:11 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 20, 2026 - 15:58 CDT

Update

We are continuing to investigate this issue.
Posted May 20, 2026 - 15:47 CDT

Investigating

We are aware of issues with loading reports in the Smokeball application. Our team is investigating.
Posted May 20, 2026 - 14:43 CDT
This incident affected: Smokeball (Reports).