Matter Details Loading

Incident Report for Smokeball USA

Resolved

This issue has been resolved and all matter information is now loading as expected. We appreciate your patience.
Posted Oct 04, 2024 - 12:58 CDT

Investigating

We are currently investigating issues with loading Matter Details.
Posted Oct 04, 2024 - 11:20 CDT
This incident affected: Smokeball (Matter Syncing).