Payments not displaying on invoices

Incident Report for Smokeball USA

Resolved

We have resolved this issue with payments not displaying on invoices, and all effected invoices are now displaying payments correctly.
Posted Jul 02, 2024 - 09:48 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 01, 2024 - 14:52 CDT

Investigating

We are currently investigating issues with payments not displaying on invoices.
Posted Jul 01, 2024 - 13:48 CDT
This incident affected: Smokeball Billing.