PDF invoices are not loading

Incident Report for Smokeball USA

Resolved

PDF invoices are now loading as expected. Thank you for your patience.
Posted Jul 12, 2024 - 08:22 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 12, 2024 - 08:17 CDT

Investigating

We are aware of issues with invoice PDFs loading. The invoices are finalizing but the PDF is not displaying. Our team is investigating the issue. Thank you!
Posted Jul 12, 2024 - 08:05 CDT
This incident affected: Smokeball Billing.