SignIT/Docusign is not working

Incident Report for Smokeball USA

Resolved

The team at InfoTrack/SignIT have resolved the issue. SignIT from Smokeball is now working as expected. Thank you for your understanding.
Posted Sep 18, 2024 - 05:53 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 17, 2024 - 18:42 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 17, 2024 - 14:43 CDT

Investigating

We are aware of issues with using the right-click SignIT function from a Smokeball matter. Our team and Infotrack team are working on a solution. You can still use SignIT but opening up Infotrack and clicking SignIT from that home page.
Posted Sep 17, 2024 - 14:18 CDT
This incident affected: Smokeball (Infotrack).