Smokeball Billing Delay

Incident Report for Smokeball USA

Resolved

We have resolved the issue with time/expense creation and invoice creation. All actions should work as normal. Thank you for your patience.
Posted Jul 01, 2024 - 12:47 CDT

Investigating

We are currently investigating Billing delays within the Smokeball web app. We will provide a status update as soon as possible.
Posted Jul 01, 2024 - 11:16 CDT
This incident affected: Smokeball Billing.