Smokeball Billing delays
Incident Report for Smokeball USA
Resolved
We have resolved the delays with billing data syncing including time/fees, payments, and invoices. Thank you for your patience.
Posted Feb 14, 2024 - 16:28 CST
Monitoring
We have implemented a fix. Data will again start to load including time and fees, payments, and invoices. There are still delays and you will be updated when fully operational. Thanks!
Posted Feb 14, 2024 - 16:12 CST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 14, 2024 - 15:59 CST
Investigating
We are aware of issues impacting time and fees, creating and finalizing invoices, and adding payments. Our team is investigating. Thank you for your patience.
Posted Feb 14, 2024 - 15:03 CST
This incident affected: Smokeball Billing.