Delays with Smokeball Billing

Incident Report for Smokeball USA

Resolved

We have resolved the issue with time/expense creation and invoice creation. All actions should work as normal. Thank you for your patience.
Posted May 29, 2024 - 11:56 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 29, 2024 - 11:43 CDT

Investigating

We are experiencing delays with the creation of time/expense entries and finalizing draft invoices. Our team is investigating. Thank you!
Posted May 29, 2024 - 11:06 CDT
This incident affected: Smokeball Billing.