Bulk billing delays

Incident Report for Smokeball USA

Resolved

Bulk billing delays have recovered. Thank you!
Posted Aug 01, 2025 - 09:20 CDT

Investigating

We are aware of issues with bulk billing this includes bulk creating drafts and bulk finalizing. Our team is investigating. Thank you!
Posted Aug 01, 2025 - 08:50 CDT
This incident affected: Smokeball Billing.