Multiple functions in Billing are not working
Incident Report for Smokeball USA
Resolved
We have resolved the outstanding issues with Billing. Thank you!
Posted Aug 25, 2023 - 10:09 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 25, 2023 - 09:30 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 25, 2023 - 09:06 CDT
Investigating
We are investigating issues impacting multiple parts of Smokeball Billing webapp. This includes creation of invoices, viewing the time expenses tab on the matter, viewing invoice pdfs, and downloading invoices. We appreciate your patience. Thank you!
Posted Aug 25, 2023 - 08:27 CDT
This incident affected: Smokeball Billing.