Multiple delays with billing platform

Incident Report for Smokeball USA

Resolved

Finalized invoices should now be loading as expected. If they are still not loading, you can edit and refinalize. Thanks for your patience.
Posted Sep 25, 2026 - 13:23 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 25, 2026 - 13:15 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 25, 2026 - 12:58 CDT

Investigating

We are aware of issues with finalizing invoices, viewing invoices, processing payments, and processing deposits. Our team is investigating. Thanks!
Posted Sep 25, 2026 - 12:42 CDT
This incident affected: Smokeball Billing.