Infotrack not loading

Incident Report for Smokeball USA

Resolved

This incident has been resolved.
Posted Feb 27, 2025 - 14:54 CST

Monitoring

We are seeing improvements with the integration. Attempts to e-file or e-sign should work but we are monitoring any issues. Thank you for your patience.
Posted Feb 27, 2025 - 12:01 CST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 27, 2025 - 11:14 CST

Investigating

We are aware of issues with e-filing and e-signing through Infotrack. It does not launch their portal. We are working with our teams to resolve.
Posted Feb 27, 2025 - 10:22 CST
This incident affected: Smokeball (Infotrack).