Finalized invoice PDFs not loading

Incident Report for Smokeball USA

Resolved

Invoice PDFs are now loading as expected. Thanks for your patience.
Posted Apr 07, 2026 - 12:13 CDT

Investigating

We are aware of the issue with newly finalized invoice PDFs not loading. Our team is investigating. Thanks
Posted Apr 07, 2026 - 11:20 CDT
This incident affected: Smokeball Billing.