Calendar syncing delays

Incident Report for Smokeball USA

Resolved

We have resolved the issue with event syncing. All events should finish syncing in the next thirty minutes. We appreciate your patience.
Posted Apr 10, 2026 - 19:45 CDT

Monitoring

A fix has been released and we are seeing events sync over. We are continuing to monitor.
Posted Apr 10, 2026 - 17:54 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 10, 2026 - 17:38 CDT

Investigating

We are aware of issues with calendar events syncing across Outlook and Smokeball. Our team is investigating. Thanks!
Posted Apr 10, 2026 - 16:40 CDT
This incident affected: Smokeball (Calendar Syncing).