Smokeball Billing trust and operating account delays
Incident Report for Smokeball USA
Resolved
We have resolved the issue of account activity delays. All transactions should now show. You can now print checks. Thanks for your patience.
Posted Feb 26, 2024 - 12:01 CST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 26, 2024 - 11:57 CST
Investigating
We are aware of multiple issues impacting the Billing platform. This includes applying payments from trust or operating accounts, depositing money into trust or operating accounts, and printing checks.. Our Development team is working on a solution. We apologize for the inconvenience and thank you for your patience.
Posted Feb 26, 2024 - 11:37 CST
This incident affected: Smokeball Billing.