Issues generating invoices
Incident Report for Smokeball USA
Resolved
Invoice are now generating as expected. Thank you for your patience.
Posted Mar 20, 2024 - 12:45 CDT
Investigating
We are aware of issues with creating draft invoices and finalizing draft invoices. Our team is investigating. Thank you!
Posted Mar 20, 2024 - 12:32 CDT
This incident affected: Smokeball Billing.