Delays when bulk creating invoices
Incident Report for Smokeball USA
Resolved
Creation of invoices via bulk billing should now work as intended. Thank you for your patience.
Posted Jul 03, 2023 - 11:31 CDT
Monitoring
A fix has been implemented. We are seeing improvements when creating bulk invoices. Thank you for your patience.
Posted Jul 03, 2023 - 11:22 CDT
Investigating
We are aware of delays when bulk finalizing invoices. Our team is investigating. Thank you for your patience.
Posted Jul 03, 2023 - 10:01 CDT
This incident affected: Smokeball Billing.