Finalized invoice PDFs not loading

Incident Report for Smokeball USA

Resolved

This incident has been resolved.
Posted Jul 24, 2026 - 14:21 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 24, 2026 - 14:01 CDT

Investigating

We are investigating an issue with finalized invoice PDFs not loading.
Posted Jul 24, 2026 - 13:35 CDT
This incident affected: Smokeball Billing.