Delays with bulk invoicing
Incident Report for Smokeball USA
Resolved
Bulk billing is now working as intended. Thank you for your patience.
Posted Oct 02, 2023 - 14:08 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 02, 2023 - 13:43 CDT
Investigating
We are aware of delays in processing bulk invoices. Our development operations team is investigating. Thank you for your patience.
Posted Oct 02, 2023 - 13:09 CDT
This incident affected: Smokeball Billing.