Matter overview section not loading in web application

Incident Report for Smokeball USA

Resolved

The matter overview page is now loading as expected. Thanks!
Posted Aug 13, 2026 - 09:06 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 13, 2026 - 08:28 CDT

Investigating

We are aware of issues with the matter overview section not showing in the web application. Other matter sections are loading as expected. We are working on a solution. Thank you!
Posted Aug 13, 2026 - 08:07 CDT
This incident affected: Smokeball Billing.