Unable to login to Smokeball web application
Incident Report for Smokeball USA
Resolved
We have resolved the login issues for the Smokeball web application and the Billing application. Thank you for your patience.
Posted Dec 12, 2023 - 15:22 CST
Investigating
We are aware of issues logging into the Smokeball web application which includes the billing application. Our team is investigating. Thank you for your patience.
Posted Dec 12, 2023 - 15:00 CST
This incident affected: Smokeball Billing.