Problems with matters loading in Smokeball

Incident Report for Smokeball USA

Resolved

All services should now be restored. Users should now be able to access matters in all parts of the software. We appreciate your patience and thank you for your understanding.
Posted Mar 09, 2026 - 12:00 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 09, 2026 - 11:24 CDT

Identified

Our team has identified the issue and we are working on a solution. We appreciate your patience.
Posted Mar 09, 2026 - 11:16 CDT

Investigating

We are aware of issues with matters not loading. That is impacting multiple areas of the software. Our team is investigating.
Posted Mar 09, 2026 - 10:26 CDT
This incident affected: Smokeball (General Use).