Smokeball Billing platform issues
Incident Report for Smokeball USA
Resolved
We have resolved the billing issues. All actions should now work as expected. Thank you for your patience.
Posted Nov 16, 2023 - 10:43 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 16, 2023 - 10:15 CST
Investigating
We are aware of multiple issues impacting the Billing platform. This includes invoice PDFs loading, posting payments, sending emails, and finalizing invoices. Our team is investigating. Thank you for your patience.
Posted Nov 16, 2023 - 09:32 CST
This incident affected: Smokeball Billing.